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This guide describes how to use Podcast Composer to create 
Podcast Producer work昀氀ows.

Mac OS X Server includes Podcast Composer, an application for creating and deploying 

Podcast Producer work昀氀ows.

Important:  Before you read this guide, make sure you familiarize yourself with 
Podcast Producer work昀氀ows by reading the relevant sections of the Podcast Producer 

Administration guide.

What’s in This Guide
This guide includes the following chapters:

Chapter  Â 1, “Podcast Composer Overview,” provides an overview of the Podcast 
Composer application.

Chapter  Â 2, “Con昀椀guring Basic Work昀氀ow Information,” describes how to set basic 
work昀氀ow information such as work昀氀ow title, copyright, and description.

Chapter  Â 3, “Con昀椀guring the Import Stage,” explains how to specify the source types 
of the input movies that your work昀氀ow processes.

Chapter  Â 4, “Con昀椀guring the Edit Stage,” covers podcast branding, which can include 
adding a watermark and introduction, title, and exit movies to the input movie.

Chapter  Â 5, “Con昀椀guring the Export Stage,” shows you how to specify the types of 
podcast you want your work昀氀ow to publish.

Chapter  Â 6, “Con昀椀guring the Publish Stage,” describes how to specify podcast 
publishing destinations.

Chapter  Â 7, “Con昀椀guring the Notify Stage,” describes how to create noti昀椀cations to 
announce the publishing of your podcast.

Chapter  Â 8, “Managing Work昀氀ows,” explains how to save, verify, and deploy your 
podcast to a Podcast Producer server.

Chapter  Â 9, “Advanced Podcast Composer Topics,” discusses advanced Podcast 
Composer such as customizing the email template and extending work昀氀ows.
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Note:  Because Apple periodically releases new versions and updates to its software, 
images shown in this book may be di昀昀erent from what you see on your screen.

Using Onscreen Help
You can get task instructions onscreen in Help Viewer while you’re managing  
Mac OS X Server v10.6. You can view help on a server or an administrator computer. 

(An administrator computer is a Mac OS X computer with Mac OS X Server v10.6 

administration software installed on it.)

To get the most recent onscreen help for Mac OS X Server v10.6:
Open Server Admin or Workgroup Manager and then: m

Use the Help menu to search for a task you want to perform. Â

Choose Help > Server Admin Help or Help > Workgroup Manager Help to browse  Â

and search the help topics.

The onscreen help contains instructions taken from Server Administration and other 

advanced administration guides described later.

To see the most recent server help topics:
Make sure the server or administrator computer is connected to the Internet while  m
you’re getting help.

Help Viewer retrieves and caches the most recent server help topics from the Internet. 

When not connected to the Internet, Help Viewer displays cached help topics.
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Document Map
Mac OS X Server v10.6 has a suite of guides that cover management of individual 

services. Each service may be depend other services for maximum utility. The 
documentation map below shows some related documentation that you may need  

in order to con昀椀gure your desired service to your speci昀椀cations. You can get these 
guides in PDF format from the Mac OS X Server Resources website:

www.apple.com/server/macosx/resources/

Podcast Composer

Explains how to
create Podcast Producer

workflows using
Podcast Composer.

Podcast Producer
Administration

Describes advanced
options for setting up,

configuring, and managing
Podcast Producer service.

Podcast Producer

Work昀氀ow Tutorial
Walks you through

the process of creating
a complete Podcast

Producer workflow.

Podcast
Capture Help

Provides onscreen
instructions and answers

when you’re using
Podcast Capture to
record and submit

content for processing
by Podcast Producer.

Viewing PDF Guides Onscreen
While reading the PDF version of a guide onscreen, you can:

Show bookmarks to see the guide’s outline, and click a bookmark to jump to the  Â

corresponding section.

Search for a word or phrase to see a list of places where it appears in the document.  Â

Click a listed place to see the page where it occurs.

Click a cross-reference to jump to the referenced section. Click a web link to visit the  Â

website in your browser.

http://www.apple.com/server/macosx/resources/
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Printing PDF Guides
If you want to print a guide, you can take these steps to save paper and ink:

Save ink or toner by not printing the cover page. Â

Save color ink on a color printer by looking in the panes of the Print dialog for an  Â

option to print in grays or black and white.

Reduce the bulk of the printed document and save paper by printing more than  Â

one page per sheet of paper. In the Print dialog, change Scale to 115% (155% 

for Getting Started). Then choose Layout from the untitled pop-up menu. If your 

printer supports two-sided (duplex) printing, select one of the Two-Sided options. 
Otherwise, choose 2 from the Pages per Sheet pop-up menu, and optionally choose 

Single Hairline from the Border menu. (If you’re using Mac OS X v10.4 or earlier,  
the Scale setting is in the Page Setup dialog and the Layout settings are in the  

Print dialog.)

You may want to enlarge the printed pages even if you don’t print double sided, 

because the PDF page size is smaller than standard printer paper. In the Print dialog  

or Page Setup dialog, try changing Scale to 115% (155% for Getting Started, which has 

CD-size pages).

Getting Documentation Updates
Periodically, Apple posts revised help pages and new editions of guides. Some revised 

help pages update the latest editions of the guides.

To view new onscreen help topics for a server application, make sure your server or  Â

administrator computer is connected to the Internet and click “Latest help topics” or 
“Staying current” in the main help page for the application.

To download the latest guides in PDF format, go to the Mac OS X Server Resources  Â

website:

www.apple.com/server/macosx/resources/

An RSS feed listing the latest updates to Mac OS X Server documentation and  Â

onscreen help is available. To view the feed use an RSS reader application, such  
as Safari or Mail:

feed://helposx.apple.com/rss/snowleopard/serverdocupdates.xml

http://www.apple.com/server/macosx/resources/
feed://helposx.apple.com/rss/snowleopard/serverdocupdates.xml
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Getting Additional Information
For more information, consult these resources:

 Â Read Me documents—get important updates and special information. Look for  
them on the server discs.

 Â Mac OS X Server website (www.apple.com/server/macosx/)—enter the gateway to 

extensive product and technology information.

 Â Mac OS X Server Support website (www.apple.com/support/macosxserver/)—access 

hundreds of articles from Apple’s support organization.

 Â Apple Discussions website (discussions.apple.com/)—share questions, knowledge, 
and advice with other administrators.

 Â Apple Mailing Lists website (www.lists.apple.com/)—subscribe to mailing lists so  

you can communicate with other administrators using email.

 Â Apple Training and Certi昀椀cation website (www.apple.com/training/)—hone 

your server administration skills with instructor-led or self-paced training, and 
di昀昀erentiate yourself with certi昀椀cation.

http://www.apple.com/server/macosx/
http://www.apple.com/support/macosxserver/
http://discussions.apple.com/
http://www.lists.apple.com/
http://www.apple.com/training/


 10

Use this chapter to learn concepts about Podcast Composer 
and how you can use it to create Podcast Producer 
work昀氀ows.

Podcast Producer work昀氀ows are self-contained 昀椀le bundles that contain all the 
information, code, and resources that Podcast Producer needs to produce podcasts.

Developing a work昀氀ow manually can be a challenging task for developers and 
nondevelopers alike because it involves editing XML 昀椀les, using Podcast Producer 
command-line tools, and ensuring that all resources are included in the right place in 

the bundle. The more complicated the work昀氀ow is, the more time it takes to build.

Podcast Composer, an application that ships with Mac OS X Server, simpli昀椀es and 
speeds up the process of building work昀氀ows by providing you with a simple graphical 
user interface. All you do is provide information about the work昀氀ow, without writing 
XML code or worrying about where to store resources and credentials.

With Podcast Composer, creative individuals and administrators can easily develop 

work昀氀ows that can be immediately used, or customized later by developers.

Podcast Composer builds highly optimized work昀氀ows that take advantage of the 
parallel processing capability o昀昀ered by Xgrid.

1Podcast Composer Overview
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How Podcast Composer Works
Podcast Composer groups the process of building a work昀氀ow into seven stages that 
step you through the process of creating a work昀氀ow:

Stage 1. Information You specify basic work昀氀ow information: work昀氀ow name, 
work昀氀ow author’s name, and a brief description of the work昀氀ow.

Stage 2. Import You tell the work昀氀ow what to expect as input: a single QuickTime 
movie, two QuickTime movies, or a set of documents that are compatible with Quick 
Look. The output of this stage is a single QuickTime movie. If the input to this stage is 
two movies, Podcast Composer produces a picture-in-picture movie. If the input to this 

stage is documents, Podcast Composer produces treats document pages as images 

and renders them into a movie with transitions between the images. If a document is  

a video, Podcast Composer concatenates it with the other documents as a movie.

Stage 3. Edit You specify how you want to brand the podcast that this work昀氀ow 
produces by adding watermarks, introduction, title, and exit movies. The output of  
this stage is called the Edited Master movie. This stage produces a high-quality movie 

at the highest possible resolution based on the resolution of the input movies. The 

Edited Master movie is a 昀氀at QuickTime media 昀椀le that is used in the following stages 
of the work昀氀ow.

Stage 4. Export You select the di昀昀erent types of encodings to be used for publishing 
your podcast. For example, you might want your podcast to be available in three 
昀氀avors: iPhone/iPod, Apple TV, and AAC (audio-only).

Stage 5. Publish You determine how the podcast is published. For example, you can 
con昀椀gure the Publish stage to publish the di昀昀erent versions of the podcast to the 
Podcast Library.

Stage 6. Notify You create the noti昀椀cations that you want the work昀氀ow to send after 
the podcast is published. You can send noti昀椀cations to users and administrators with 
instruction on how to access the podcast. You can also send noti昀椀cations to services to 
let them know that new content is published to the Podcast Library.

Stage 7. Summary You verify your selections. If no more changes are required, you 

deploy the work昀氀ow to Podcast Producer server.

When working on a particular stage, Podcast Composer keeps the previous and next 
stages in view to provide context.

The work昀氀ow that you generate using Podcast Composer is a 昀椀le bundle. A work昀氀ow 
bundle contains the code, resources, credentials, work昀氀ow description, and all the 
information needed to execute the work昀氀ow.

In the Export, Publish, and Notify stages, you can’t have more than nine elements  
per stage.



Navigating the Podcast Composer Stages
Podcast Composer provides several ways to view and navigate stages.

Using the Arrow Keys
Use the Up and Down arrow keys to move from one stage to another. Â

Use the Right and Left arrow keys to move among items in a stage. Â

Using the Commands in the Stages Menu
To move to a stage, choose Stage >  Â stage name or use the Command-[stage  

number] shortcut. For example, to go to the Edit stage, choose Stages > Edit or  
press Command-3.

To move up or down the stages, use the Stages > Previous or Stages >   Â

Next command.

To view all stages at once, choose Stages > Overview or press Command-Return.   Â

To return to the normal view, use the same command. This command lets you 

switch between normal and overview views. You can also double-click the header  
of a stage to run the Overview mode.

You can also use the Tab and Shift-Tab keys for navigation.

Obtaining Help
To access Podcast Composer onscreen help, use the Help menu.

To access context-sensitive help about a stage, click the Help (?) button at the bottom 
right of the active stage.

Creating a Work昀氀ow
This section describes how to create a work昀氀ow using Podcast Composer.

To create a work昀氀ow in Podcast Composer:
 1 Open Podcast Composer (in /Applications/Server/).

 2 Choose File > New.

 3 Choose File > Save.

 4 In the Save As dialog box, enter the name of the work昀氀ow bundle and specify where 
to store it.

The name that you enter in this 昀椀eld can be di昀昀erent from the name you specify in  
the Information stage.

 5 Go through stages 1 to 6 to con昀椀gure your work昀氀ow. 
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Remember to periodically save your work昀氀ow while working on it.

To con昀椀gure basic work昀氀ow settings, see Chapter  Â 2, “Con昀椀guring Basic Work昀氀ow 
Information.”

To specify the input source type, see Chapter  Â 3, “Con昀椀guring the Import Stage.”

To brand your podcast, see Chapter  Â 4, “Con昀椀guring the Edit Stage.”

To specify the output formats for your podcast, see Chapter  Â 5, “Con昀椀guring the 
Export Stage.”

To specify destinations for your podcast, see Chapter  Â 6, “Con昀椀guring the Publish 
Stage.”

To con昀椀gure noti昀椀cations announcing the publishing of your podcast, see  Â

Chapter 7, “Con昀椀guring the Notify Stage.”

 6 Save your work昀氀ow (see “Saving a Work昀氀ow” on page 57).

 7 Verify your work昀氀ow (see “Verifying a Work昀氀ow” on page 59).

 8 Deploy your work昀氀ow (see “Deploying a Work昀氀ow” on page 60).

To extend your work昀氀ow, or to learn about advanced Podcast Composer topics,  
see Chapter 9, “Advanced Podcast Composer Topics.”
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Use this chapter to set the name, author, and description 
information of a work昀氀ow.

Every work昀氀ow de昀椀nes a set of metadata or information about the work昀氀ow. Podcast 
Composer lets you de昀椀ne three 昀椀elds that are referenced in Podcast Producer server: 
Work昀氀ow Name, Author, and Description.

Con昀椀guring Basic Work昀氀ow Information
In the 昀椀rst Podcast Composer stage, Information, you specify the following information 
or metadata:

Work昀氀ow Name—The name of the work昀氀ow. This is the name that appears in the  Â

Work昀氀ow pane of the Podcast Producer service. It also appears in the Work昀氀ow 
drop-down menu in Podcast Capture. This name can be di昀昀erent from the name you 
give to the Work昀氀ow bundle you create with Podcast Composer.

Author—The name of the work昀氀ow’s author information for your work昀氀ow. When  Â

building your work昀氀ow in Podcast Composer, you can con昀椀gure the work昀氀ow 
settings to display the author information in the resulting podcast.

2Con昀椀guring Basic Work昀氀ow 
Information
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Description—A brief description of your work昀氀ow. The description you enter here  Â

helps Podcast Producer administrators and Podcast Capture users understand what 

the work昀氀ow does.

When you create a work昀氀ow bundle with Podcast Composer, the Work昀氀ow  
Name, Author, and Description metadata is stored in the Info.plist 昀椀le inside the 
work昀氀ow’s bundle.

To set the work昀氀ow name, author, and description information:
 1 In Podcast Composer, go to the Information stage (choose Stages > Information or 

press Command-1).

 2 In the Work昀氀ow Name 昀椀eld, enter the name of the work昀氀ow as you want it to appear 
in Server Admin and Podcast Capture.

 3 In the Author 昀椀eld, enter the author information for your work昀氀ow.

 4 In the Description 昀椀eld, enter a brief description of your work昀氀ow.

 5 Choose File > Save.
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Use this chapter to learn how to specify the types of the 
input sources to the work昀氀ow in the Import stage of Podcast 
Composer.

In the Import stage, you select the input source of the content your work昀氀ow 
processes. Podcast Composer provides three choices:

Single Source—A single QuickTime movie as input to the work昀氀ow. The QuickTime  Â

movie can be a video recording, a screen recording, or an audio-only recording.

Dual Source—Two QuickTime movies (with video tracks) as input to the work昀氀ow.  Â

For this choice, you cannot use a source with only an audio track. For example, a 
video recording of a lecturer and a screen recording of the lecturer’s slides. The 

video recordings can come from a remote camera and a local screen, two remote 

cameras, or a local camera and local screen.

3Con昀椀guring the Import Stage
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Montage—Documents as input to the work昀氀ow. These documents can be movies,  Â

images, Keynote presentations, Pages documents, PDF 昀椀les, Word 昀椀les, and 
PowerPoint 昀椀les.

The output of the Import stage is a single movie, which is also the input movie to the 

next stage, Edit.



Con昀椀guring Single Source
If you want the work昀氀ow to create a podcast from only one QuickTime movie, select 
and con昀椀gure the Single Source option of the Import stage.

To con昀椀gure the Single Source option of the Import stage:
 1 In Podcast Composer, go to the Import Stage (choose Stages > Import or press 

Command-2).

 2 Double-click Single Source, or move your mouse over the Single Source icon and click 
the Information button in the bottom-right corner of the icon.

If Single Source is selected, you can press Enter to display the Information dialog.

 3 From the Single Source Type pop-up menu, choose one of the following options to 

specify the type of recording Podcast Capture users can use with this work昀氀ow:

Any—The input movie can be a video recording, a screen recording, or an audio- Â

only recording.

Video Device Only—The input movie is a video recording. Â

Screen Recorder Only—The input movie is a screen recording. Â

Audio Only—The input movie is an audio-only recording. Â

 18  Chapter 3    Con昀椀guring the Import Stage
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 4 If you want the work昀氀ow to automatically detect changes in the input movie and use 
this information to assign chapters in the generated podcast, select Automatic Chapter 

Generation.

In the case of a screen recording, the work昀氀ow inserts a chapter marker in the video 
when it detects a slide transition or when no changes occur in the video at a certain 

moment. This is useful when doing a screen recording or for any video that includes 

presentations.

The tool used by the work昀氀ow to add chapter markers detects stability in a movie by 
comparing frames and after the tool 昀椀nds a stable sequence, it considers it a chapter. 
Then, when the sequence changes to another sequence, the tool consider that change 

a transition.

Chapter markers are recommended for screen recordings, but not for video and audio 
recordings. However, there are instances when adding these markers is useful, such 
as when the source video is for a screen recording captured from the VGA or DVI 
stream of a computer screen. Screen recording using Podcast Capture works only on a 
computer running Mac OS X v10.5 or later.

 5 Click Done.

 6 Choose File > Save.



Con昀椀guring Dual Source
If you want the work昀氀ow to create a podcast from two QuickTime movies, select 
and con昀椀gure the Dual Source option of the Import stage—for example, a screen 
recording of a presentation and a video of the presenter.

Important:  It is recommended that you provide the audio of the entire recording in 

the video of the presenter and not within the screen recording.

To con昀椀gure the Dual Source option of the Import stage:
 1 In Podcast Composer, go to the Import Stage (choose Stages > Import or press 

Command-2).

 2 Double-click Dual Source, or move your mouse over the Dual Source icon and click the 
Information button in the lower-right corner.

A dialog appears, displaying the settings that you can con昀椀gure and a live preview box 
that re昀氀ects your selections.

 3 From the Dual Source Composition pop-up menu, choose one of the following 

composition options to specify how the two input videos are going to be composed 

to create the 昀椀nal movie:

 20  Chapter 3    Con昀椀guring the Import Stage
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Keynote Presentation—This picture-in-picture composition displays the screen  Â

recording movie in full screen and hides the second movie. After 15 seconds (by 

default) this composition minimizes the screen recording movie, moves it to the right, 

and displays the second movie in the bottom-left corner of the screen. Finally, after 15 

seconds (by default) the composition brings back the screen recording movie into full 
screen and hides the second movie. This process repeats for the duration of the movie.

Overlay—This picture-in-picture composition displays the screen recording movie  Â

in full screen and overlays the second movie in the bottom-right corner of the 

screen. Then, in response to conditions in the screen recording (for example, a slide 
doesn’t change for more than 20 seconds) the location of the overlay is switched, if 

transition detection is enabled. If transition detection is not enabled, both movies 

remain in their original positions.

Overlay with Fade—This composition is similar to the Overlay composition, but  Â

instead of keeping the second movie in view all the time, this composition fades the 
movie in and out at certain intervals (10 seconds by default).

Theater—This composition is similar to the Overlay composition, except that you  Â

always have a full view of the screen recording movie. This option is ideal if you 

don’t want any part of the screen recording to be covered by the other movie.

 4 If you want Podcast Composer to automatically detect transitions in the screen 

recording movie, select Automatic Transitions.

With this option enabled, Podcast Composer can detect slide transitions in the movie 

and use this information to determine when to switch movies in the composition.

If you choose not to automatically detect transitions, there will be no transition.  

The selected dual source composition remains static. Both movies remain in their 
original positions.

 5 If you want Podcast Composer to automatically detect changes in the input movies 

and use this information to assign chapters in the generated podcast, select Automatic 

Chapter Generation.

For example, you might want chapters in the podcast to mark each transition to a  
new slide.

In the case of a screen recording, the work昀氀ow inserts a chapter marker in the video 
when it detects a slide transition or when no changes occur in the video for a certain 

moment. This is useful when doing a screen recording or for any video that includes 

presentations.

The tool used by the work昀氀ow to add chapter markers detects stability in a movie by 
comparing frames. When the tool 昀椀nds a stable sequence, it considers it a chapter. 
Then, when the sequence changes to another sequence, the tool consider that change 

a transition.

 6 Click Done.

 7 Choose File > Save.



Con昀椀guring Montage
If you want the work昀氀ow to create a podcast from movies, images, Keynote 
presentations, Pages documents, PDF 昀椀les, Word 昀椀les, and PowerPoint 昀椀les, select and 
con昀椀gure the Montage option of the Import stage. 

Podcast Composer treats the pages of these documents as images. It combines all 

pages of all documents into one slide presentation and generates a QuickTime video 
of the presentation.

For example, if your input is a PDF document and a Word document, Podcast 
Composer treats each page in these documents as an image. Then, Podcast Composer 

assembles these images into one presentation and uses the settings you specify for 

the Montage option to generate a QuickTime movie of a slide show of the images.

If a document isn’t in landscape mode, displaying a page in full for each slide results in 

text that might be hard to read because the page can’t 昀椀ll the entire width of the slide. 
To solve this problem, Podcast Composer slices each document page in half. The upper 

half image of a page appears on one slide and the bottom half image appears on the 

following slide. Podcast Composer also adds a transition between the two slides to 

provide a scrolling e昀昀ect.
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The documents are ordered in the slide show by their alpha-numeric order based on 

the 昀椀le names of the source documents.

To con昀椀gure the Montage option of the Import stage:
 1 In Podcast Composer, go to the Import Stage (choose Stages > Import or press 

Command-2).

 2 Double-click Montage, or move your mouse over the Montage icon and click the 
Information button in the lower-right corner.

A dialog appears, displaying the settings that you can con昀椀gure and a live preview 
video that re昀氀ects your selections.

 3 In the Image Duration 昀椀eld, enter the number of seconds that each slide is displayed.

 4 To specify a transition e昀昀ect:

From the Transition E昀昀ect pop-up menu, choose an e昀昀ect. Â

From the Direction pop-up menu, choose the direction of the e昀昀ect (if applicable). Â

In the Duration 昀椀eld, specify the duration of the transition in seconds. Â



 5 If you want Podcast Composer to automatically detect changes in the input movies 

and use this information to assign chapters in the generated podcast, select Automatic 

Chapter Generation.

For example, you might want chapters in the podcast to mark each transition to a  
new slide.

In the case of documents, every page is considered a chapter. The work昀氀ow uses  
Quick Look to extract a title from these pages, if available, to assign a meaningful title 
to chapters. If not available, Podcast Composer uses the 昀椀lename.

 6 Click Done.

 7 Choose File > Save.
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Use this chapter to con昀椀gure the introduction, title, and exit 
movies, and add a watermark to your podcast.

In the Edit stage of Podcast Composer, you can brand your podcast by adding any of 

the following items:

Introduction movie—For example, you might want your podcasts to start with a  Â

10-second movie that displays you organization’s logo.

Title movie—For example, you might want your podcast to have a title screen that  Â

displays information extracted from the work昀氀ow’s metadata, such as title, author, 
copyright, and description.

Watermark—For example, you might want the podcast to display the logo of your  Â

organization as a watermark.

Exit movie—For example, you might want your podcasts to end with the same  Â

movie, giving credit to your organization.

4Con昀椀guring the Edit Stage



You can also add transitions between these items.

In the Edit stage, Podcast Composer places the branding items and the input movie in 

a timeline from left to right, in the following default order:

Introduction movie (optional)  Â

Transition (optional) Â

Title movie (optional) Â

Transition (optional) Â

Input movie Â

Transition (optional) Â

Exit movie (optional) Â
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In the Edit stage, you can drag movies and watermarks onto the corresponding 
elements in the timeline and in dialog boxes.

In the Edit stage, you can also:

Use the Remove (–) button or press Backspace to remove an optional item. Use the  Â

Add (+) button to add an item. To delete all optional items, press Command-Delete.

Skim through video clips in the timeline to preview video content. Â

Use the Preview button to preview the movie that will be generated by the Edit stage. Â



Adding and Con昀椀guring an Introduction Movie
By default, the 昀椀lm strip in the Edit stage includes an introduction movie. If an 
introduction movie isn’t present, click the Add (+) button and select Introduction to 
add the movie.

To con昀椀gure the introduction movie:
 1 In Podcast Composer, go to the Edit stage (choose Stages > Edit or press Command-3).

 2 Double-click the icon of the introduction movie.

 3 From the Introduction movie pop-up menu, choose a default introduction movie that 

comes with Podcast Composer.

To select a custom movie, select Choose, browse for the movie, select it, and click 
Open. You can also drag the movie onto the preview movie in the pop-up menu.

You can also drag a movie directly onto the icon of the introduction movie without 

opening the pop-up menu.

 4 Click Done.

 5 Choose File > Save.
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Adding and Con昀椀guring a Title Movie
By default, the 昀椀lm strip in the Edit stage includes a title movie. If it isn’t present, click 
the Add (+) button and select Title to add the movie.

To con昀椀gure the title movie:
 1 In Podcast Composer, go to the Edit stage (choose Stages > Edit or press Command-3).

 2 Double-click the icon of the title movie.

 3 From the Bumper title pop-up menu, choose one of the default styles.

 4 From the Logo media, if enabled, choose a default style. You can also select Choose to 

add your own logo, or drag the logo onto the preview video.

 5 Select the items to include in the title video:

Title Â

Date Â

Copyright Â

Description Â

Author Â

Organization Â



Depending on your selection from the Bumper title pop-up menu, some of these 
items might be disabled.

 6 Click Done.

 7 Choose File > Save.

Adding and Con昀椀guring a Watermark and an Introduction 
Overlay
You can use the Edit stage to add a watermark and an introduction overlay to the 
input movie.

A watermark can be an image, a movie, or a Quartz Composition.

An introduction overlay is a title that appears on top of the movie for a speci昀椀ed 
amount of time at the beginning of the movie.
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To add a watermark to the input movie:
 1 In Podcast Composer, go to the Edit stage (choose Stages > Edit or press Command-3).

 2 Double-click the icon of the input movie.

 3 From the Watermark pop-up menu, choose a default watermark style.

To use a custom watermark, select Choose and select the watermark. You can also drag 
the watermark onto the preview movie.

You can also drag a watermark onto the watermark and introduction overlay icon 
without opening the pop-up menu.

 4 To specify the opacity of the watermark, move the Opacity slider to the left (more 
transparent) or to the right (less transparent).

 5 To specify the size of the watermark, move the Sizing slider to the left (smaller) or to 
the right (bigger).

 6 To specify the position of the watermark, choose an option from the Position  
pop-up menu.

You can also drag the logo to one of the other corners of the preview movie.

 7 To add an introduction overlay over the input movie and under the watermark,  
choose an overlay style from the Introduction overlay pop-up menu. 

Select the information to display in the overlay by selecting checkboxes. Depending 
on the overlay style you choose, some of the checkboxes might be disabled.

You can also drag a movie onto the watermark and introduction overlay icon without 
opening the pop-up menu.

 8 Click Done.

 9 Choose File > Save.



Adding and Con昀椀guring an Exit Movie
By default, the 昀椀lm strip in the Edit stage includes an exit movie. If an exit movie isn’t 
present, click the Add (+) button and select Exit to add the movie.

To con昀椀gure the exit movie:
 1 In Podcast Composer, go to the Edit stage (choose Stages > Edit or press Command-3).

 2 Double-click the icon of the exit movie.

 3 From the Exit movie pop-up menu, choose a default exit movie that comes with 
Podcast Composer.

To select a custom movie, select Choose from the pop-up menu, browse for the movie, 

select it, and click Open. You can also add an exit movie by dragging the movie onto 
the live preview box.

 4 Click Done.

 5 Choose File > Save.
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Con昀椀guring Transitions
You can con昀椀gure transitions between movies in the Edit stage.

To con昀椀gure transitions:
 1 In Podcast Composer, go to the Edit stage (choose Stages > Edit or press Command-3).

 2 Double-click the icon of the transition.

 3 Choose a transition from the Transition pop-up menu.

If you don’t need a transition, choose None.

 4 If the Direction pop-up menu is enabled, choose the direction of the transition.

 5 If the Duration 昀椀eld is enabled, enter the duration of the transition in seconds.

 6 Click Done.

 7 Choose File > Save.



Previewing the Podcast
The Edit stage provides a live preview window where you can preview the QuickTime 
movie generated by the Edit stage. While the window is open, changes you make in 
the Edit stage are instantly re昀氀ected in the live preview.

To open the live preview window:
 1 In Podcast Composer, go to the Edit stage (choose Stages > Edit or press Command-3).

 2 Click the Preview button.

To display a bigger live preview window, alt-click the Preview button.
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Use this chapter to learn how to specify the encoding 
formats to use for publishing your podcast.

In the Export stage of Podcast Composer, you select output formats for your podcast. 
For example, to optimize your podcast for iPhones and Apple TV, you can select those 
two formats in the Export stage. For every format you select in the Export stage, 
Podcast Composer creates a corresponding task in the work昀氀ow.

Podcast Composer supports the following QuickTime encoding formats:

Apple TV Â

Video:  H.264 Video, 1280 x 720, 5 Mbps, 30 fps

Audio:  AAC-LC Music, Stereo, 128 kbps, 44.1 kHz

Audio Â

Video:  None

Audio:  AAC-LC Music, Stereo, 128 kbps, 44.1 kHz

Computer Â

Video:  H.264 Video, 1920 x 1080, 10 Mbps, 30 fps

Audio:  AAC, Stereo, 256 kbps, 44.1 kHz

iPod / iPhone Â

Video:  H.264 Video, 640 x 480, 1.5 Mbps, 30 fps

Audio:  AAC-LC Music, Stereo, 128 kbps, 44.1 kHz

Mobile Â

Video:  H.264 Video, 176 x 144, 56 kbps, 15 fps
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Audio:  AAC-LC Music, Mono, 24 kbps, 16 kHz

Podcast Composer lets you specify custom encoding formats that you create with the 

Compressor application, which must be installed on the computer running Podcast 

Composer and launched at least once before you can use it with Podcast Composer. 

The Compressor application should also be installed on the Xgrid nodes used by 

Podcast Producer to run the work昀氀ow.

Compressor is a post-production application. It ships with Final Cut Studio.

Note:  Only a few default Compressor encodings are playable on an iPod or iPhone. 

Before deploying a custom composition, be sure it 昀椀ts the target device requirements.
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Adding QuickTime Encoding Formats
You can add up to four QuickTime encoding formats in the Export stage.

To add a QuickTime encoding format to the Export stage:
 1 In Podcast Composer, go to the Export stage (choose Stages > Export or press 

Command-4).

 2 Click the Add (+) button.

If the Compressor plug-in is installed, a pop-up menu appears.

 3 Choose QuickTime.

A QuickTime encoder is added to the Export stage and a dialog box appears.

 4 From the QuickTime Encoder pop-up menu, choose the encoder you want to use.

 5 Click Done.

 6 Choose File > Save.



Adding Compressor Formats
Podcast Composer supports encoding formats that you create using the Compressor 

application. However, you must 昀椀rst install Compressor on your computer. For more 
information on how to install Compressor, see the Compressor documentation.

To add Compressor encoding formats to the Export stage:
 1 In Podcast Composer, go to the Export stage (choose Stages > Export or press 

Command-4).

 2 Click the Add (+) button.

 3 From the pop-up menu, choose Compressor.

A Compressor encoder is added to the Export stage and a dialog appears.

 4 From the Compressor Encoder pop-up menu, choose the encoder you want to use.

This menu shows the custom encodings you created using Compressor.

 5 To use the Apple Qmaster distributed processing system to speed up the encoding 

process, click “Use remote Qmaster” enter the required information.

Apple Qmaster speeds up encoding of a movie at a time by dividing the total number 

of frames in a job into smaller segments. Each of the processing computers then works 
on a di昀昀erent segment. Because the nodes are working in parallel, the job is 昀椀nished 
sooner than it would be on a single computer.

Note:  To produce a podcast as fast as possible, use Compressor (running on Xgrid) and 

Qmaster (with segment and encoding setup). To produce many podcasts as fast as 

possible, use default encoders or Compressor running on Xgrid.

For more information about the Apple Qmaster distributed processing system, see 

Apple Qmaster 2 and Compressor 2 Distributed Processing Setup.

 6 Click Done.

 7 Choose File > Save.
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Use this chapter to specify and con昀椀gure the publishing 
destinations of your podcast.

In the Publish stage, you specify a destination for each podcast export format you 
added in the Export stage.

The Publish stage supports the following content destinations:

Podcast Library Â

Apple Wiki (optional) Â

File Transfer (optional) Â

Final Cut Server (optional) Â

Folder (optional) Â

Work昀氀ow (optional) Â
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Sending Content to the Podcast Library
The Podcast Library is where Podcast Producer stores published content. The Podcast 

Library publishes the content through Atom or RSS feeds, and keeps track of your 
content automatically.

Podcast Library is the default Podcast Producer distribution system in Mac OS X Server 

v10.6. This provides an easy solution out of the box.

For more information about Podcast Library, see Podcast Producer Administration.
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To add the Podcast Library to the Publish stage:
 1 In Podcast Composer, go to the Publish stage (choose Stages > Publish or press 

Command-5).

By default, the Podcast Library is added to the Publish stage.

 2 Double-click the Podcast Library element.

 3 In the dialog box, from “Publish media 昀椀les to Podcast Library” pop-up menu, select the 
media 昀椀le to publish to the Podcast Library:

Original Sources—Select this option to archive the original source 昀椀les used to  Â

create your podcast.

Preview Files—Select this option to archive the preview 昀椀les generated by Podcast  Â

Composer.

Edited Master—Select this option to archive the edited master 昀椀le from which  Â

encoded content is generated. This is a high-quality 昀氀at movie that you may need 
later if you want to re-encode the podcast using a di昀昀erent format.

Generated Media Files—Select this option to publish the media 昀椀les generated by  Â

the work昀氀ow.

 4 (Optional) In the Tags 昀椀eld, add tags, separated by commas, to make it easier to 昀椀nd 
your content.

The Podcast Library adds these tags to every published media 昀椀le, and creates a feed 
for every tag.

Tags are a good and easy way to create multiple feeds for the same podcast. For 

example, you might want to have some podcasts be accessible based on the year of 
the class and the department’s name.

 5 Click Done.

 6 Choose File > Save.



Sending Content to an Apple Wiki Server
One way to publish podcasts is to post your podcast on an Apple blog. You can add 

one or more Apple blog destinations.

To post a podcast to an Apple wiki:
 1 In Podcast Composer, go to the Publish stage (choose Stages > Publish or press 

Command-5).

 2 Click the Add (+) button and choose Apple Wiki.

A dialog box appears.

 3 From the “Podcast to post to the Apple wiki” pop-up menu, choose the podcast format 
for posting to the blog.

 4 In the Server 昀椀eld, enter the address of the blog.

 5 If the wiki requires Secure Socket Layer protection, select Use Secure Socket Layer 
(SSL).

 6 In the User Name and Password 昀椀elds, enter the administrator credentials to access  
the blog.

 7 To specify the destination of the podcast in the blog, select one of the following options:
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Submitting user’s blog—The blog of the user who submitted the podcast. Â

Custom blog—In the corresponding 昀椀eld, enter the user name of the blog’s owner. Â

Custom wiki—In the corresponding 昀椀eld, enter the group name required for  Â

accessing the wiki.

 8 Click Done.

 9 Choose File > Save.

Sending Content Using File Transfer Protocols
Podcast Composer lets you send content to backup 昀椀le systems using these 昀椀le 
transfer protocols:

FTP Â

FTPS Â

SFTP Â

WebDav Â

WebDavs Â

You can add one or more File Transfer destinations.



To send a podcast to a backup 昀椀le system:
 1 In Podcast Composer, go to the Publish stage (choose Stages > Publish or press 

Command-5).

 2 Click the Add (+) button and choose File Transfer.

A dialog appears.

 3 From the “Podcast to transfer” pop-up menu, choose the podcast format for backing 
up to the 昀椀le system.

 4 From the Protocol pop-up menu, choose the 昀椀le transfer protocol to use.

 5 In the Server 昀椀eld, enter the address of the server to send the 昀椀les to.

 6 In the Path 昀椀eld, enter the path to where the podcast should be stored.

 7 In the User Name and Password 昀椀elds, enter the administrator credentials to access the 
昀椀le system.

 8 Click Done.

 9 Choose File > Save.
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Sending Content to the Watch Folder of Final Cut Server
In the Publish stage of Podcast Composer, you can choose to send content to the 

Watch folder of Final Cut Server for further processing.

You can add one or more Final Cut Server destinations.

To submit content to Final Cut Server:
 1  In Podcast Composer, go to the Publish stage (choose Stages > Publish or press 

Command-5).

 2 Click the Add (+) button and choose Final Cut Server.

A dialog appears.

 3 From the “Podcast to copy” pop-up menu, choose the podcast format for sending to 
Final Cut Server.

 4  In the “Path to Final Cut Server Watch Folder” 昀椀eld, enter the path to the Watch folder.

Important:  The path you specify must have write access for the pcastxgrid user.

 5 Click Done.

 6 Choose File > Save.



Sending Content to a Shared Folder
The Publish stage of Podcast Composer lets you send content to a shared folder.  

You can add one or more shared folder destinations.

To send content to a shared folder:
 1 In Podcast Composer, go to the Publish stage (choose Stages > Publish or press 

Command-5).

 2 Click the Add (+) button and choose Folder.

A dialog appears.

 3 From the “Podcast to copy” pop-up menu, choose the podcast format for sending to  
the shared folder.

 4 In the “Path to Shared Folder” 昀椀eld, enter the path to the shared folder.

Important:  The path you specify must have write access for the pcastxgrid user.
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 5 To use day folders, select “Use day folders.”

This option creates an intermediate folder for every day of the year to store all content 

published on that day. 

 6 Click Done.

 7 Choose File > Save.

Sending Content to a Work昀氀ow
You might want to send your podcast to another custom work昀氀ow or work昀氀ow chain 
deployed on the Podcast Producer server to perform additional tasks that you can’t 
con昀椀gure in Podcast Composer.

You can add one or more work昀氀ow destinations. 

To send content to a work昀氀ow:
 1  In Podcast Composer, go to the Publish stage (choose Stages > Publish or press 

Command-5).

 2 Click the Add (+) button and choose Work昀氀ow.



A dialog appears.

 3 Click the Add (+) button to add media 昀椀les to the list of media 昀椀les to send to Podcast 
Producer.

 4 In the Work昀氀ow 昀椀eld, enter the name of the work昀氀ow that Podcast Producer will use to 
process the submitted content.

 5 In the User Name and Password 昀椀elds, enter the user credentials needed to submit the 
job to Podcast Producer.

 6 Click Done.

 7 Choose File > Save.
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Use this chapter to learn how to create noti昀椀cations, which 
Podcast Producer sends to announce published podcasts.

In the Notify stage of Podcast Composer, you add and con昀椀gure noti昀椀cations to be 
sent to users announcing the publishing of podcasts.

You can add the following types of noti昀椀cations:

Email Â

iChat Â

iTunes Podcast Directory Â

iTunes U Â

Service Â
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Adding Email Noti昀椀cations
In the Notify stage, you can add one or more email noti昀椀cations.

To add an Email noti昀椀cation:
 1 In Podcast Composer, go to the Notify stage (choose Stages > Notify, or press 

Command-6).

 2 Click the Add (+) button and choose Email.

A dialog appears.

 3 Select the mail recipients:

Podcast Producer administrator—Select this option to send an email noti昀椀cation to  Â

the administrator of the Podcast Producer server.

This information is stored in the DIrectory Service. In Workgroup Manager, you can 
set up this information for every user.

Submitting user—Select this option to send an email noti昀椀cation to the user who  Â

submitted the work昀氀ow.

This information is stored in the DIrectory Service. In Workgroup Manager, you can 
set up this information for every user.
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Others—Select this option and enter the email addresses (separated by commas)   Â

of the noti昀椀cation recipients.

 4 In the Email address 昀椀eld, enter the address of the person sending the email.

 5 In the Server 昀椀eld, enter the address of the server used for sending the email.

 6 If the email requires Secure Socket Layer protection, select Use Secure Socket Layer (SSL).

 7 From the Authentication pop-up menu, choose the authentication type.

 8 In the User name and Password 昀椀elds, enter the administrator credentials to send  
the email.

 9 Click Done.

 10 Choose File > Save.

Adding iChat Noti昀椀cations
In the Notify stage, you can add iChat noti昀椀cations.

For iChat noti昀椀cations to work, you need access to an iChat server running on  
Mac OS X Server v10.6. If not, you must set up your own iChat server. Noti昀椀cations fail  
if sent through an iChat server running on Mac OS X Server v10.5 or earlier.

However, if you need to send the noti昀椀cations through an iChat server running on 
v10.5, you can set up an iChat server on a computer running v10.6 and federate it to 

an iChat server running on a computer with v10.5. The noti昀椀cations 昀椀rst go through 
the iChat server running on the v10.6 computer and then through the iChat server 

running on the v10.5 server.

The iChat server doesn’t need to run on the Podcast Producer server.



For more information about setting up an iChat server, see iChat Service Administration.

To add an iChat noti昀椀cation:
 1  In Podcast Composer, go to the Notify stage (choose Stages > Notify, or press 

Command-6).

 2 Click the Add (+) button and choose iChat.

A dialog appears.

 3 Select the iChat recipients:

Podcast Producer administrator—Select this option to send an iChat noti昀椀cation  Â

message to the administrator of the Podcast Producer server.

This information is stored in the DIrectory Service. In Workgroup Manager, you can 
set up this information for every user.

Submitting user—Select this option to send an iChat noti昀椀cation message to the  Â

user who submitted the work昀氀ow.

This information is stored in the DIrectory Service. In Workgroup Manager, you can 
set up this information for every user.
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Others—Select this option and enter the iChat addresses (separated by commas) of  Â

the noti昀椀cation recipients.

 4 In the Jabber ID and Password 昀椀elds, enter the administrator credentials to send the 
iChat message.

iChat noti昀椀cations work with Jabber accounts only.

The ichat address of the sender should be di昀昀erent from the address of the Podcast 
Producer administrator and the submitter.

 5 In the iChat message 昀椀eld, enter the text of the noti昀椀cation message to be sent via iChat.

When Podcast Producer receives a job, it generates the properties.plist 昀椀le which 
contains metadata, including the Podcast Producer properties de昀椀ned in Server Admin.

In the iChat noti昀椀cation message, you can add $$KEY$$ variables, which are replaced 
by the values of these keys de昀椀ned in the properties.plist 昀椀le.

For example, to display the full name of the user who submitted the job (Bill James), 
use $$User Full Name$$ in the iChat message. The Xgrid agent processing the job 
replaces $$User Full Name$$ with Bill James.

For more information about de昀椀ning Podcast Producer variables and the properties.
plist 昀椀le, see Podcast Producer Administration.

 6 To add publishing information to the iChat message, select “Display publishing 

information.”

 7 Click Done.

 8 Choose File > Save.

Adding iTunes Podcast Directory Noti昀椀cations
In the Notify stage, you can add only one iTunes Podcast Directory noti昀椀cation. For 
this noti昀椀cation to work, you must 昀椀rst register your feeds with iTunes. When this 
noti昀椀cation is sent to iTunes, the iTunes podcast repository syncs with your Podcast 
Library as soon as possible to re昀氀ect all changes. This action is asynchronous.

For more information about Podcast Library and how to register feeds with iTunes,  

see Podcast Producer Administration.

To add an iTunes Podcast Directory noti昀椀cation:
 1  In Podcast Composer, go to the Notify stage (choose Stages > Notify or press 

Command-6).

 2 Click the Add (+) button and choose iTunes Podcast Directory.

 3 Choose File > Save.



Adding iTunes U Noti昀椀cations
In the Notify stage, you can add iTunes U noti昀椀cations. You specify the address of the 
iTunes U site to send the noti昀椀cation to. Upon receiving the noti昀椀cation, iTunes U syncs 
with the feeds you registered with it as soon as possible. This action is asynchronous.

Before sending iTunes U noti昀椀cations, you must register feeds with the iTunes U site. 
For more information, contact the iTunes U site administrator.

To add an iTunes U noti昀椀cation:
 1  In Podcast Composer, go to the Notify stage (choose Stages > Notify or press 

Command-6).

 2 Click the Add (+) button and choose iTunes U.

A dialog appears.

 3 Enter the address of the iTunes U site.

 4 Click Done.

 5 Choose File > Save.
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Adding Third-Party Service Noti昀椀cations
In the Notify stage, you can add Service noti昀椀cations. You specify the URL of the 
service to ping.

When the service receives the ping, the service performs the prede昀椀ned actions.

To add a Service noti昀椀cation:
 1  In Podcast Composer, go to the Notify stage (choose Stages > Notify or press 

Command-6).

 2 Click the Add (+) button and choose Service.

A dialog appears.

 3 Enter the URL of the service.

 4 Click Done.

 5 Choose File > Save.
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Use this chapter to learn how to use Podcast Composer to 
verify, deploy, and manage work昀氀ows.

Podcast Composer allows to upload and download work昀氀ows from Podcast Producer 
server. Podcast Composer also allows you to verify work昀氀ows to ensure that they 
contain all required information.

Viewing a Summary of the Work昀氀ow
The last stage in Podcast Composer provides a bird’s-eye view of your work昀氀ow by 
listing the icons of the tasks you’ve de昀椀ned in your work昀氀ow. Use this stage to make 
sure your work昀氀ow is complete.

8Managing Work昀氀ows
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To see a summary of your work昀氀ow:
In Podcast Composer, go to the Summary stage (choose Stages > Summary or press  m
Command-7).

Saving a Work昀氀ow
To save a work昀氀ow in Podcast Composer, use the Save or Save As command from the 
File menu. You can also use the Save button in the Summary stage.

When you save a work昀氀ow, Podcast Composer generates a work昀氀ow bundle that 
contains all information and resources needed to process the work昀氀ow. This includes 
images, movies, presets, templates, tools, and compositions used by the work昀氀ow.

The work昀氀ow bundle also includes work昀氀ow metadata, password information, and the 
XML code that de昀椀nes the work昀氀ow. The bundle also contains your credentials and the 
Xgrid job template the de昀椀nes the tasks to execute and which tasks can be executed 
in parallel.

If the work昀氀ow has credentials, they are secured using a master password stored in 
your keychain.

To save a new work昀氀ow:
 1 Choose File > Save (Command-S) or press the Save button in the Summary stage.

 2 In the Save As dialog, enter the name of the work昀氀ow bundle and specify where  
to store it.

The name that you enter in this 昀椀eld can be di昀昀erent than the name you speci昀椀ed in 
the Information stage.

 3 Click Save.

To save changes to an existing work昀氀ow bundle, choose File > Save (Command-S) or 
press the Save button in the Summary stage.

To change the name of a work昀氀ow bundle, choose File > Save As (Command-Shift-S).

 4 In the Save As dialog, enter the new name of the work昀氀ow bundle.

Note:  A work昀氀ow can be saved even if not complete and not correct.



Using the Work昀氀ow Inspector
The Work昀氀ow Inspector in Podcast Composer lets you:

Specify the poster image for the podcast. This is the image associated with the  Â

published podcast. If you don’t specify a poster image, Podcast Composer extracts a 
poster image from a frame that’s about one third of the way into the presentation.

View work昀氀ow statistics. The inspector displays the number of tasks in the work昀氀ow  Â

and the maximum number of tasks that can be run in parallel.

Add notes about the work昀氀ow to the Work昀氀ow Notes 昀椀eld. These notes are stored  Â

as metadata in the info.plist 昀椀le at the root level of the work昀氀ow bundle.

To open the Work昀氀ow Inspector:
 1 In Podcast Composer, choose Window > Work昀氀ow Inspector.

 2 To set the work昀氀ow’s poster image, drag a .png or .ti昀昀 image onto the Episode Poster 
Image 昀椀eld.

 3 To add notes about the work昀氀ow, enter the text in the Work昀氀ow Notes 昀椀eld.
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Verifying a Work昀氀ow
Before deploying a completed work昀氀ow, it is good practice to verify the work昀氀ow, 
even though Podcast Composer veri昀椀es it before deploying it. By verifying the 
work昀氀ow, you can deploy it at a moment’s notice.

To verify a work昀氀ow in Podcast Composer:
 1 Choose File > Verify Work昀氀ow (Command-Y).

If the work昀氀ow isn’t con昀椀gured correctly, a message appears describing the problem 
with the 昀椀rst work昀氀ow element that has missing settings. Podcast Composer displays a 
red arrow pointing to the element in question.

 2 If an error message appears:

 a Click OK to dismiss the dialog.

 b Fix the problem.

 c Verify the work昀氀ow again.

You might need to repeat these steps several times until the work昀氀ow passes 
veri昀椀cation.

 3 When the work昀氀ow is con昀椀gured correctly and a message appears indicating 
successful work昀氀ow con昀椀guration, click OK.



Deploying a Work昀氀ow
When you 昀椀nish building a work昀氀ow, you can use Podcast Composer to upload 
the work昀氀ow bundle to a Podcast Producer server. Podcast Producer makes the 
work昀氀ow available to Podcast Capture clients, as determined by the Podcast Producer 
administrator.

Before you can deploy a work昀氀ow, make sure you have the necessary credentials to 
access the Podcast Producer server.

To deploy a work昀氀ow to a Podcast Producer server:
 1 In Podcast Composer, choose File > Deploy to Server (Command-U) or press the 

Deploy button on the Summary stage.

If your work昀氀ow is incomplete, a dialog appears describing the problem with the 昀椀rst 
incomplete setting in the work昀氀ow. Podcast Composer displays a red arrow pointing 
to the element that has the incomplete setting.

 2 If a dialog appears indicating that the work昀氀ow is incomplete, click the OK button to 
dismiss the dialog, 昀椀x the problem, and then try to deploy the work昀氀ow again.

You might need to repeat the process several times until the work昀氀ow passes 
veri昀椀cation.

 3 In the Server 昀椀eld of the Deploy dialog, enter the address of the Podcast Producer 
server or choose a server from the pop-up menu.

 4 Click Deploy.

 5 In the Name and Password 昀椀elds, enter the administrator user name and password 
assigned to you by the Podcast Producer administrator.

If a work昀氀ow with the same name or same unique identi昀椀er exists, Podcast Composer 
prompts you whether to overwrite the work昀氀ow, install the work昀氀ow with a di昀昀erent 
unique identi昀椀er, or cancel the operation.

What makes a work昀氀ow unique is a unique identi昀椀er (UUID). This means that you can 
have multiple work昀氀ows with the same name, as long as the UUIDs are di昀昀erent.

 6 Click Deploy again.

A dialog box appears indicating that the work昀氀ow was successfully uploaded to the 
Podcast Producer server.

When you deploy a work昀氀ow, Podcast Producer changes the name of the work昀氀ow to 
an automatically generated name. For example:

631CDEA3-AC0D-4DC8-BF7E-1A24DC306A02.pwf

Podcast Producer also adds checksum information to the work昀氀ow to ensure integrity.
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Opening a Work昀氀ow Remotely
To make a local copy of a work昀氀ow residing on a Podcast Producer server, use the  
File > Open Remote command in Podcast Composer.

To open a work昀氀ow remotely in Podcast Composer:
 1 Choose File > Open Remote (Command-Shift-O).

 2 In the Server 昀椀eld of the Open Remote Work昀氀ow window, select a Podcast Producer 
server or enter its and then click Connect.

 3 In the Name and Password 昀椀elds, enter the user name and password assigned to you 
by the Podcast Producer administrator.

 4 Click Connect again.

 5 Choose the work昀氀ow you want to edit from the Work昀氀ow list.

 6 Click Open.

 7 In the Save As 昀椀eld, enter the name of the work昀氀ow.

 8 In the Where 昀椀eld specify where to store the work昀氀ow.

 9 Click Save.

Podcast Composer opens the work昀氀ow so you can make changes to it.



 62

Use this chapter to perform advanced Podcast Composer 
tasks such as customizing email templates and Quartz 
Composer compositions.

Extending Podcast Composer Work昀氀ows
Podcast Composer helps you quickly generate self-contained work昀氀ows that are ready 
for deployment. However, you might want to extend your work昀氀ow in a way that isn’t 
possible in Podcast Composer.

To extend your work昀氀ow, you can con昀椀gure it in the Publish stage of Podcast 
Composer to send the output of the work昀氀ow to another work昀氀ow that you manually 
created. The second work昀氀ow adds your custom tasks to the work昀氀ow for execution.

Alternatively, you can take the work昀氀ow generated by Podcast Composer and extend 
it manually. To learn more about work昀氀ows and how to con昀椀gure them manually, see 
Podcast Producer Administration and Podcast Producer Work昀氀ow Tutorial.

WARNING:  If you create a work昀氀ow using Podcast Composer and then manually 
extend the work昀氀ow, you can’t edit it again in Podcast Composer.

9Advanced Podcast Composer 
Topics
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Making Resources Available to Podcast Composer
Podcast Composer stores all the resources needed to build a work昀氀ow in its 
application bundle. These resources are grouped in the /Applications/Server/Podcast 

Composer/Contents/Resources/Materials/ folder.

These resources are:

Compositions Â

Images Â

Movies Â

Templates Â

Themes Â

When you create a new work昀氀ow in Podcast Composer, only resources inside the 
application’s bundle are available to you. If you need to add your own resources (for 

example, a watermark or introduction and exit movies), you have to manually add 
them through drag and drop or by browsing.

However, you can make your own resources available to Podcast Composer by storing 
them in one of the following folder:

/Library/Application Support/Podcast Composer/Resources/—Resources stored in  Â

this folder are available to all users.

~/Library/Application Support/Podcast Composer/Resources/—Resources stored in  Â

this folder are available to one user.

By default, the ~/Library/Application Support/Podcast Composer/Resources/ folder 
contains an empty folder structure that mimics the folder structure of the the contents 

of the /Applications/Server/Podcast Composer/Contents/Resources/Materials/ folder.

To store resources in the /Library/Application Support/Podcast Composer/Resources/ 
folder, you must 昀椀rst create the same folder structure as that of the Materials folder.



Important:  If two resources with the same name are in the ~/Library/Application 

Support/Podcast Composer/Resources/ and /Library/Application Support/Podcast 
Composer/Resources/ folders, Podcast Composer lists both.

To make your resources available to Podcast Composer:
 1 Quit Podcast Composer.

 2 Store the resources in the relevant folders.

For example, to make your introduction movies available to Podcast Composer, store 
them in the ~/Library/Application Support/Podcast Composer/Resources/Movies/
Introduction/ folder.

 3 Launch Podcast Composer.

 4 Verify that the resources are now available to Podcast Composer.

For example, to verify that your custom introduction movie is now available to Podcast 
Composer, in the Edit stage, double-click the Introduction movie icon. Your movie 
should be listed in the User Content section of the Introduction movie pop-up menu.

Tip:   ∏ When you highlight a resource in the User Content section of the pop-up menu, a 

tooltip displays the path to the resource. 
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Working with Themes
By default, Podcast Composer ships with one theme. However, if you add custom 
themes, Podcast Composer displays the Theme button in the Edit stage, which lets you 

select a theme to apply to your podcast.

“ Â Customizing Podcast Composer Themes” on page 65

“ Â Applying a Theme to a Podcast” on page 70

Customizing Podcast Composer Themes
Podcast Composer ships with only one theme bundle (Apple Podcast.pwt). This theme 

is in /Applications/Server/Podcast Composer/Contents/Resources/Materials/Themes/.

A theme de昀椀nes the following aspects of a podcast:

Introduction movie—Whether to add an introductory movie to the podcast. Â

Introduction movie transition—Whether to add a transition between the  Â

introductory movie, and the following movie and the properties of the transition.

Watermark properties—Whether to add a watermark to the input movie, and the  Â

properties of the watermark.



Title movie—Whether to add a title movie to the podcast. Â

Title movie transition—Whether to add a transition between the title movie and the  Â

input movie, and the properties of the transition.

Exit movie—Whether to add an exit movie to the podcast Â

Exit movie transition—Whether to add a transition between the input movie and  Â

the exit movie, and the properties of the transition.

To create themes, copy the default theme (Apple Podcast.pwt), rename the copy, and 

customize it as needed.

If you plan to deploy multiple computers for creating work昀氀ows in your organization 
using Podcast Composer, make sure the 昀椀les referenced by the theme are accessible 
from all computers.

To create a custom theme㨀̀

 1 Copy the default theme (/Applications/Server/Podcast Composer/Contents/Resources/
Materials/Themes/Apple Podcast.pwt) to the following folder:

~/Library/Application Support/Podcast Composer/Resources/Themes/

If this folder is not there, create it.

 2 Rename the theme bundle.

 3 Open the bundle.

 4 Modify the following 昀椀les:

Contents/Info.plist—See “ Â Modifying Info.plist” on page 67.

Contents/Resources/en.lproj/InfoPlist.strings—See “ Â Modifying InfoPlist.strings”  
on page 67.

Contents/Resources/theme.plist—See “ Â Modifying theme.plist” on page 67.

You can also add your own resources to the bundle if needed. 

When modifying these 昀椀le, you can test your changes by restarting Podcast Composer 
and applying your custom theme.
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Modifying Info.plist

In the Contents/Info.plist 昀椀le, change the values of the following keys:

CFBundleIdenti昀椀er—Change the last part in the theme bundle identi昀椀er to re昀氀ect  Â

the name of your theme bundle:

com.apple.PodcastWork昀氀ow.theme.custom_name

CFBundleName—The name of the theme bundle. This name should match the last  Â

part of the theme bundle identi昀椀er.

Version—Specify the version of the theme. Â

Modifying InfoPlist.strings

For every supported language in the theme bundle, there is an InfoPlist.strings 昀椀le, 
which contains localized strings. The English version of InfoPlist.strings is in Contents/

Resources/en.lproj/InfoPlist.strings.

In the InfoPlist.strings 昀椀le for every language you’re supporting, change the values of 
the following keys:

Copyright—The copyright string for this theme. Â

Description—The description of the theme. Â

Name—The name of the theme. This name, unlike the name of the theme bundle,  Â

can contain spaces.

Modifying theme.plist

The Contents/theme.plist 昀椀le de昀椀nes the theme’s attributes. You can customize the 
following attributes of a theme:

Introduction movie Â

Introduction movie transition Â

Watermark properties Â

Title movie Â

Title movie transition Â

Exit movie Â

Exit movie transition Â

Specifying the Introduction Movie
In the theme.plist 昀椀le, the intro key lets you de昀椀ne the path to the introduction movie.

To specify an intro movie, under <key>intro</key>, replace the value of the path key 
with the path to your introductory movie.

If Podcast Composer cannot 昀椀nd your movie, it uses the introduction movie of the 
default theme (Apple Podcast.pwt).



Con昀椀guring the Introduction Movie Transition
To con昀椀gure the introduction movie transition, under the introTransition key, modify 
the values of the following keys:

direction—The direction of the transition as a number between 0 and  Â n-1, where n 

is the possible number of directions.

duration—The duration in seconds. Â

path—The path to the Quartz Composer transition. Â

Con昀椀guring the Title Movie
In the theme.plist 昀椀le, the title key lets you con昀椀gure a title movie.

To specify a title movie, under <key>title</key>, modify the values of the following keys:

authorEnabled—If true, adds the name of the person submitting the podcast to the  Â

title movie.

copyrightEnabled—If true, adds the copyright text (de昀椀ned in the Default Properties  Â

list of Podcast Producer in Server Admin) to the title movie.

dateEnabled—If true, adds the date on which the podcast was submitted. Â

descriptionEnabled—If true, adds the description (provided by the person  Â

submitting the podcast) to the title movie.

organizationEnabled—If true, adds the name of the organization (de昀椀ned in the  Â

Default Properties list of Podcast Producer in Server Admin) to the title movie.

path—The path to the Quartz Composer composition that de昀椀nes how the title  Â

movie is rendered.

titleEnabled—If true, adds the title of the podcast (provided by the person  Â

submitting the podcast) to the title movie

Con昀椀guring the Title Movie Transition
To con昀椀gure the title movie transition, under the titleTransition key, modify the values 
of the following keys:

direction—( Â If applicable) The direction of the transition as a number between 0 and 

n-1, where n is the possible number of directions.

The numbers match the array provided by the transition in the Info.plist 昀椀le of  
the transition.

duration—The duration in seconds. Â

path—The path to the Quartz Composer transition. Â
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Con昀椀guring the Watermark
In the theme.plist 昀椀le, the contentWatermark key lets you con昀椀gure a title movie.

To con昀椀gure the watermark, under <key>contentWatermark</key>, modify the values 
of the following keys:

opacity—The opacity of the watermark as a numerical value between 0 and 100,  Â

with 0 being invisible and 100 being opaque (no transparency).

path—The path to the watermark. Ideally, the watermark must be a .png 昀椀le.  Â

However, you can use other formats such as jpeg and PDF.

position—The position of the watermark as a number between 0 and 3: Â

Top left:  0 Â

Top right:  1 Â

Bottom left:  2 Â

Bottom right:  3 Â

sizing—The size of the watermark as a value between 0 and 40. Â

Specifying the Exit Movie
In the theme.plist 昀椀le, the outro key lets you de昀椀ne the path to the exit movie.

To specify an exit movie, under <key>outro</key>, replace the value of the path key 
with the path to your exit movie.

If Podcast Composer cannot 昀椀nd your movie, it uses the exit movie of the default 
theme (Apple Podcast.pwt).

Con昀椀guring the Exit Movie Transition
To con昀椀gure the exit movie transition, under the outroTransition key, modify the values 
of the following keys:

direction—( Â If applicable) The direction of the transition as a number between 0 and 

n-1, where n is the possible number of directions.

The numbers match the array provided by the transition in the Info.plist 昀椀le of  
the transition.

duration—The duration in seconds. Â

path—The path to the Quartz Composer transition. Â



Applying a Theme to a Podcast
Themes provide a consistent look and feel to your podcast, especially if your podcast 
consists of movies created by di昀昀erent people.

To select a theme for your podcast:
 1 In Podcast Composer, go to the Edit stage (choose Stages > Edit or press Command-3).

 2 Click the Theme button in the Edit stage of Podcast Composer.

 3 Choose a theme from the pop-up menu.

A dialog appears prompting you to con昀椀rm that changing the theme modi昀椀es your 
current settings in the Edit stage.

 4 Click Yes to change the theme; otherwise, click No.

 5 Choose File > Save.

Working with Quartz Composer Compositions
Podcast Composer provides a number of Quartz Composer compositions. However, 

you can create your own and make them available to Quartz Composer.

“ Â Creating Quartz Composer Compositions” on page 70

“ Â Selecting a Custom Quartz Composer Compositions” on page 72

Creating Quartz Composer Compositions
You can customize Quartz Composer compositions that ship with Podcast Producer or 

you can create your own compositions. However, you must have strong familiarity with 

Apple’s Quartz Composer, the application you use to create Quartz compositions.

The default Quartz Composer compositions that ship with Podcast Producer are in the 

following folder:

/Applications/Server/Podcast Composer/Contents/Resources/Materials/Compositions/

This folder contains the following folders:

DualSource Â

This folder stores the dual source transitions, which you can access in the Edit  

stage of Podcast Composer. For example, the Keynote.pqz bundle represents the 
Keynote composition.

Titles Â

This folder contains two folders:

Bumper contains the bumper title composition bundles.

Overlay contains the overlay title composition bundles.
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Transitions Â

This folder contains the transition bundles.

To customize Quartz Composer compositions or create new ones, you must install 

Quartz Composer on your computer. Quartz Composer is included with the Mac OS X 

developer tools.

To customize Quartz Composer compositions㨀̀

 1 Copy the Quartz Composer composition you want to edit to the relevant folder inside 

the following folder:

~/Library/Application Support/Podcast Composer/Resources/Compositions/

 2 Rename the Quartz Composer composition.

The name of the Podcast Producer Composition that wraps a Quartz Composition 

must end with .pqz.

 3 Locate the Info.plist 昀椀le inside the Quartz Composer composition bundle (Contents/
Info.plist).

 4 Open the Info.plist 昀椀le.

 5 Change the value of the CFBundleIdenti昀椀er key by replacing the name of the old 
Quartz Composer composition with the new name.

The value of this key should match the name of the composition bundle. For 
example, if you copy a dual source composition and name it C2.pqz, the value of the 
CFBundleIdenti昀椀er key should be com.apple.PodcastProducer.composition.dualsource.C2.

You can also change the Threshold key in the Info.plist 昀椀le for dual source 
compositions. This key de昀椀nes the length of time the video has to stay static before  
a transition is triggered.

The default values of the Threshold key are:

Overlay composition:  20 seconds Â

Keynote composition:  15 seconds Â

Overlay with Fade composition:  10 seconds Â

Theater composition:  20 seconds Â

 6 Change the values of the localized keys listed in Info.plist.

For example, to change the values of the English strings, open Contents/Resources/
en.lproj/InfoPlist.strings and change the Copyright, Name, and Description strings to 
re昀氀ect the properties of the new composition.

 7 Save Info.plist.



 8 Locate the Quartz Composer 昀椀le (ends with .qtz) which de昀椀nes the composition.

For example, Contents/Resources/DualSource.qtz.

A .qtz 昀椀le is a Quartz Composer composition.

 9 Rename the 昀椀le.

 10 Open the Quartz Composer 昀椀le using Quartz Composer, customize it as needed, and 
save your changes.

 11 Replace the Preview.mov 昀椀le (Contents/Resources/Preview.mov) with a new preview 
movie of the composition.

Selecting a Custom Quartz Composer Compositions
Custom Quartz Composer compositions appears in the User Content area of the  

pop-up menu listing all available compositions.
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Customizing the Email Template
Podcast Composer uses an email template to compose email noti昀椀cations.  
This template resides inside the Podcast Composer application bundle  

(/Applications/Podcast Composer/Contents/Resources/Materials/Templates/Mail/).

You can customize the template in two ways:

Modify the images used by the default email template Â

Modify the template itself, which is not recommended unless you have the   Â

requisite knowledge

If you add a custom email template, Podcast Composer displays the Mail Template 

button in the Email dialog, which lets you select the mail template to use.

To customize the email template:
 1 Locate the Podcast Composer email template bundle:

/Applications/Podcast Composer/Contents/Resources/Materials/Templates/Mail/Apple 
Podcast.pmu

 2 Copy the email bundle “Apple Podcast.pmu” to the following folder:

~/Library/Application Support/Podcast Composer/Resources/Templates/Mail/

 3 Rename the email bundle.



 4 In the Contents/Info.plist 昀椀le inside the bundle, change the value of the 
CFBundleIdenti昀椀er key by replacing ApplePodcast with the new name.

This name need not be the same as the name of the .pmu bundle. No spaces are 

allowed in the name. This name serves as a unique identi昀椀er of the bundle.

 5 In the Contents/Resources/en.lproj/InfoPlist.strings, change the values of the 
Copyright, Name, and Description Strings.

The Name string contains the name of the template that appears in Podcast Producer.

If you support other languages, modify the corresponding InfoPlist.strings 昀椀le.

 6 In the Contents/Resources/en.lproj/Localizable.strings 昀椀le, change the strings that 
appear in the email noti昀椀cations.

If you support other languages, modify the corresponding Localizable.strings 昀椀le.

 7 To customize the images used in the email noti昀椀cations, replace the contents of the 
PodcastCapture.png and Spacer.png 昀椀les (in /Resources/Images/) with your own content.

Do not change the names of these 昀椀les because they are referenced in the  
part.html.erb 昀椀le.

 8 To customize the actual email template, edit the HTML code in the following 昀椀le:

~/Library/Application Support/Podcast Composer/Resources/Templates/Mail/Apple 
Podcast.pmu/Contents/Resources/Templates/part.html.erb

CAUTION:  When editing this 昀椀le, take extra caution. If this 昀椀le is not edited properly, 
email noti昀椀cations might fail.
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